Welcome Guest | RSS

My Menu

Calendar
«  October 2011  »
SuMoTuWeThFrSa
      1
2345678
9101112131415
16171819202122
23242526272829
3031

CATEGORY

Recent News

Iklan

Main » 2011 » October » 5 » RIP (Routing Information Protocol)
22.03
RIP (Routing Information Protocol)


RIP adalah sebuah routing protocol jenis distance vector yang sejati. RIP mengirimkan routing table yang lengkap ke semua interface yang aktif setiap 30 detik, batas maksimal hop di RIP hanya 15 hops dan hop 16 di anggap unreacble. RIP v1 mengunakan hanya classful routing, classful adalah suatu protocol dimana protocol ini tidak membawa routing msk informasi ketika update routing  atau routing advertisement dan tidak support VLSM dan subnetting. RIP V2 menggunakan classless routing  yang mengirimkan info subnet mask bersama dengan update-update route.

Berikut Contoh pengaplikasian RIP dalam Jaringan :


Router 1 ( GEDUNG 1) :
- Interface Fa0/1 = 192.168.10.1/24
- Interface Fa0/0 = 172.16.1.1/24
- PC 0 = 192.168.10.100
- PC 1 = 192.168.10.200

Router 2 ( GEDUNG 2) :
- Interface Fa0/1 = 192.168.20.1/24
- Interface Fa0/0 = 172.16.1.2/24
- PC 2 = 192.168.20.100
- PC 3 = 192.168.20.200

Konfigurasi di Router GEDUNG 1 :

<code>
hostname "GEDUNG 1"
!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.10.1 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.10.0
 no auto-summary
!
!
line con 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
</code>

Konfigurasi di Router GEDUNG 2 :

<code>
hostname "GEDUNG 2"
!
interface FastEthernet0/0
 ip address 172.16.1.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.20.1 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.20.0
 no auto-summary
!
!
line con 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
</code>

cek routing RIP di Gedung 1 sudah mendapat segmen LAN Gedung 2

GEDUNG 1#sh ip route rip
     172.16.0.0/30 is subnetted, 1 subnets
R    192.168.20.0/24 [120/1] via 172.16.1.2, 00:00:06, FastEthernet0/0
GEDUNG 1#

Begitu Juga segmen LAN Gedung 1 sudah teradvertise di Gedung 2

GEDUNG 2#sh ip route rip
     172.16.0.0/30 is subnetted, 1 subnets
R    192.168.10.0/24 [120/1] via 172.16.1.1, 00:00:00, FastEthernet0/0
GEDUNG 2#

Test Ping :

GEDUNG 2#ping 172.16.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 31/31/32 ms

GEDUNG 2#ping 192.168.10.100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 78/87/94 ms

GEDUNG 2#

It's Done



Category: Cisco | Views: 1063 | Added by: Ardi | Rating: 0.0/0
Total comments: 0
Name *:
Email *:
Code *:
  SHAREIT   Main   Registration   Login  
search

Entries archive

MY Link
Paid2YouTube.com
Adsense Indonesia
Review shareit.ucoz.net on alexa.com

ilkan

WIDGET

Site friends
  • M. Danu Wiyoto
  • Hacker Cisadane


  • Copyright MyCorp © 2024 Free web hostinguCoz