Welcome Guest | RSS

My Menu

Calendar
«  Juni 2011  »
SuMoTuWeThFrSa
   1234
567891011
12131415161718
19202122232425
2627282930

CATEGORY

Recent News

Iklan

Main » 2011 » Juni » 18 » Redistribusi Routing RIP dan BGP
12.37
Redistribusi Routing RIP dan BGP


aye mo share lagi nich tentang Redistribution Route, sebelumnya aye mo jelasin dulu yang di maksud dengan Redistribution, Redistribution adalah proses yang mengizinkan suatu informasi routing protokol untuk untuk di ketahui routing protokol lainnya.

Dengan Redistribute kita dapat membentuk routing table yang lengkap pada suatu topologi walaupun menggunakan routing protokol yang berbeda.

Pada prinsipnya router yang menjadi penghubung antara network dengan routing protocol yang berbeda akan menggunakan routing protocol sesuai dengan routing protocol yang dipergunakan oleh kedua network tersebut, misal pada router R2 interface F0/0 pada router tersebut berhubungan dengan network yang menggunakan RIP maka router tersebut harus menggunakan RIP dan pada F1/0 menggunakan BGP maka router tersebut juga harus menggunakan BGPsesuai dengan network tempat interface tersebut terhubung. Untuk membuat agar routing tabel yang dibentuk oleh RIP bisa diteruskan menuju ke BGP maka dipergunakan redistribute RIP, dan sebaliknya agar routing tabel yang terbentuk pada BGP bisa diteruskan menuju RIP maka dipergunakanlah redistribute BGP

contoh sederhana seperti ini



R1
f0/0 = 172.16.1.1 255.255.255.252
lo1 = 192.168.1.1 255.255.255.0 
lo2 = 192.168.2.1 255.255.255.0
lo3 = 192.168.3.1 255.255.255.0

R2
f0/0 = 172.16.1.2 255.255.255.252
f1/0 = 172.16.2.2 255.255.255.252

R3
f0/0 = 172.16.2.1 255.255.255.252
lo1 = 10.0.1.1 255.255.255.0 
lo2 = 10.0.2.1 255.255.255.0
lo3 = 10.0.3.1 255.255.255.0 


routing yang di konfigurasi di setiap Router


R1
router rip
version 2
network 172.16.0.0
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
no auto-summary

R3
router bgp 1
network 10.0.1.0 mask 255.255.255.0
network 10.0.2.0 mask 255.255.255.0
network 10.0.3.0 mask 255.255.255.0
neighbor 172.16.2.2 remote-as 64573
no auto-summary

R2
router rip
network 172.16.0.0
passive-interface FastEthernet1/0

router bgp 64573
neighbor 172.16.2.1 remote-as 1

dengan setting seperti ini kita baru bisa ping dari router R2 ke router R1 dan Router R2 ke Router R3, tapi belum bisa ke Router R3 ke Router R1 begitu sebaliknya


R2#p 10.0.1.0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.1.0, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/19/36 ms
R2#p 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/13/32 ms
R3#p 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R3#

cek routing di R1 dan R3 masih belum terkomunikasi antar R1 dan R3

R1#sh ip rou
     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
C    192.168.1.0/24 is directly connected, Loopback1
C    192.168.2.0/24 is directly connected, Loopback2
C    192.168.3.0/24 is directly connected, Loopback3
R1#

R3#sh ip rou
     172.16.0.0/30 is subnetted, 2 subnets
C       172.16.2.0 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 3 subnets
C       10.0.2.0 is directly connected, Loopback2
C       10.0.3.0 is directly connected, Loopback3
C       10.0.1.0 is directly connected, Loopback1

sekarang konfigurasi redistribusi di router R2 untuk menghubungkan routing R1 dan R3

R2

router rip
redistribute bgp 64573 metric 6 ( untuk meredistribute bgp di rip)

buat route map dengan perintah seperti ini

route-map RIP>BGP 2120

tambahkan redistribusi rip di BGP dengan route map yang kita buat sebelumnya

router bgp 64573
redistribute rip route-map RIP>BGP
sekarang cek routing di R3 routing dari rip sudah si redistribusi

R3#sh ip rou

     172.16.0.0/30 is subnetted, 2 subnets
B       172.16.1.0 [200/0] via 172.16.2.2, 00:35:52
C       172.16.2.0 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 3 subnets
C       10.0.2.0 is directly connected, Loopback2
C       10.0.3.0 is directly connected, Loopback3
C       10.0.1.0 is directly connected, Loopback1
B    192.168.1.0/24 [200/1] via 172.16.1.1, 00:35:51
B    192.168.2.0/24 [200/1] via 172.16.1.1, 00:35:51
B    192.168.3.0/24 [200/1] via 172.16.1.1, 00:35:51
R3#

Cek routing di R1 dari BGP sudah terdistribusi

R1#sh ip rou

     172.16.0.0/30 is subnetted, 2 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
R       172.16.2.0 [120/1] via 172.16.1.2, 00:00:09, FastEthernet0/0
     10.0.0.0/24 is subnetted, 3 subnets
R       10.0.2.0 [120/6] via 172.16.1.2, 00:00:09, FastEthernet0/0
R       10.0.3.0 [120/6] via 172.16.1.2, 00:00:09, FastEthernet0/0
R       10.0.1.0 [120/6] via 172.16.1.2, 00:00:09, FastEthernet0/0
C    192.168.1.0/24 is directly connected, Loopback1
C    192.168.2.0/24 is directly connected, Loopback2
C    192.168.3.0/24 is directly connected, Loopback3


R1#p 10.0.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/27/48 ms
R1#p 10.0.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/20/28 ms
R1#

R3#p 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/72/92 ms
R3#p 192.168.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/17/28 ms
R3#



Category: Cisco | Views: 610 | Added by: Ardi | Rating: 0.0/0
Total comments: 0
Name *:
Email *:
Code *:
  SHAREIT   Main   Registration   Login  
search

Entries archive

MY Link
Paid2YouTube.com
Adsense Indonesia
Review shareit.ucoz.net on alexa.com

ilkan

WIDGET

Site friends
  • M. Danu Wiyoto
  • Hacker Cisadane


  • Copyright MyCorp © 2017 Free web hostinguCoz