Welcome Guest | RSS

My Menu

Calendar
«  Juni 2011  »
SuMoTuWeThFrSa
   1234
567891011
12131415161718
19202122232425
2627282930

CATEGORY

Recent News

Iklan

Main » 2011 » Juni » 16 » KONFIGURASI DASAR MPLS VPN
21.09
KONFIGURASI DASAR MPLS VPN


Meneruskan thread yang ini MPLS …. aye mo bikin implementasi di jaringan untuk topology MPLS dasar
[Image: 73356302933602885811.jpg]

Interface yang harus di configurasi di setiap router sbb, untuk konfigurasi interface dah pada bisakan banyak ko di thread yang sebelumnya
BRANCH
s0/0 = 174.0.2.2/30
lo0 = 150.0.2.0/24
lo1 = 150.0.20.0/24
HQ
s0/0 = 174.0.1.2/31
lo0 = 150.0.1.0/24
lo1 = 150.0.10.0/24
ISPR1
s1/0 = 174.0.1.1/30
f0/0 = 192.168.12.1/30
lo0 = 1.1.1.1
ISPR2
f1/0 = 192.168.23.1/30
f0/0 = 192.168.12.2/30
lo0 = 2.2.2.2
ISPR3
f1/0 = 192.168.23.2/30
f0/0 = 192.168.34.2/30
lo0 = 2.2.2.2
ISPR4
s1/0 = 174.0.2.1/30
f0/0 = 192.168.34.1/30
lo0 = 4.4.4.4

setelah itu step-step yang harus di lakukan adalah
1. Konfigurasi RIPv2 di HQ dan BRANCH ( CE = Customer Edge)
2. Konfigurasi EIGRP untuk internal network ISP
3. Mengaktifkan MPLS di internal network ISP
4. Membuat vrf contoh hacker_cisadane
5. Konfigurasi BGP untuk komunikasi router PE (Provider Edge)


untuk konfigurasi di HQ dan Branch menggunakan routing RIPv2
Code:
HQ :
router rip
version 2
network 150.0.0.0
network 174.0.0.0
no auto-summary


BRANCH :
router rip
version 2
network 150.0.0.
network 174.0.0.
no auto-summary

selanjutnya konfigurasi EIGRP untuk routing internal di ISP


ISPR1
router eigrp 1
network 1.1.1.1 0.0.0.0
network 192.168.12.0

ISPR2
router eigrp 1
network 2.2.2.2 0.0.0.0
network 192.168.12.0
network 192.168.23.0

ISPR3
router eigrp 1
network 3.3.3.3 0.0.0.0
network 192.168.34.0
network 192.168.23.0

ISPR4
router eigrp 1
network 4.4.4.4 0.0.0.0
network 192.168.34.0

saat ini kita sudah bisa ping untuk internal network ISP
ISPR4#ping 1.1.1.1
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/92/96 ms


untuk mengaktifkan MPLS cukup dengan mengetikan perintah ip cef dan mengetikan mpls ip di interface internal ISP contoh ISPR1 (fa0/0), ISPR2(fa0/0 dan fa1/0), ISPR3 (fa0/0 dan fa1/0) , ISPR4 (fa0/0), dan dengan ketik sh mpls forwarding-table kita dapat melihat labeling di router ISPR4, dengan begini MPLS sudah aktif
contoh :


ip cef

int fa0/0
mpls ip


ISPR4#sh mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     16          192.168.12.0/24   0          Fa0/0      192.168.34.2
17     17          1.0.0.0/8         0          Fa0/0      192.168.34.2
18     Pop tag     192.168.23.0/24   0          Fa0/0      192.168.34.2
19     Pop tag     3.0.0.0/8         0          Fa0/0      192.168.34.2
20     19          2.0.0.0/8         0          Fa0/0      192.168.34.2

Pop tag adalah interface yang bertemu langsung ISPR4, dengan ini packet di encapsulasi dan di tambahkan header MPLS dan di distribusikan melalui tagging yang mempercepat pendistribusian packet dan di saat sampai ke router yang terakhir header mpls akan di hapus dan yang akan di terima customer menjadi packet ip kembali.

Setelah MPLS aktif di lajutkan dengan membuat vrf, vrf yang aye buat adalah hacker_cisadane yang di pasang hanya di router PE ( ISPR1 dan ISPR4) dan memasang routing rip di interface kea rah router CE


ISPR4
ip vrf hacker_cisadane
rd 4.4.4.4:1
route-target both 1:1

interface Serial1/0
ip vrf forwarding hacker_cisadane
ip address 174.0.2.1 255.255.255.252
router rip
version 2
address-family ipv4 vrf hacker_cisadane
network 174.0.2.0
no auto-summary

Code:
ISPR1
ip vrf hacker_cisadane
rd 1.1.1.1:1
route-target both 1:1

interface Serial1/0
ip vrf forwarding hacker_cisadane
ip address 174.0.1.1 255.255.255.252

router rip
version 2
address-family ipv4 vrf hacker_cisadane
network 174.0.1.0
no auto-summary


sekarang IP 174.0.x.x udah ga ada di global network ISP
Code:
ISPR1#sh ip rou

     192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.12.0/30 is directly connected, FastEthernet0/0
D       192.168.12.0/24 is a summary, 02:03:51, Null0
     1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       1.1.1.1/32 is directly connected, Loopback0
D       1.0.0.0/8 is a summary, 02:04:09, Null0
D    2.0.0.0/8 [90/156160] via 192.168.12.2, 01:39:11, FastEthernet0/0
D    3.0.0.0/8 [90/158720] via 192.168.12.2, 01:39:11, FastEthernet0/0
D    4.0.0.0/8 [90/161280] via 192.168.12.2, 01:39:11, FastEthernet0/0
D    192.168.23.0/24 [90/30720] via 192.168.12.2, 01:39:11, FastEthernet0/0
D    192.168.34.0/24 [90/33280] via 192.168.12.2, 01:39:11, FastEthernet0/0

Sekarang router lebih spesifik dengan vrf


ISPR1#sh ip rou v hacker_cisadane

Routing Table: hacker_cisadane
Gateway of last resort is not set

     174.0.0.0/30 is subnetted, 2 subnets
C       174.0.1.0 is directly connected, Serial1/0
R       150.0.1.0 [120/1] via 174.0.1.2, 00:00:21, Serial1/0
R       150.0.10.0 [120/1] via 174.0.1.2, 00:00:21, Serial1/0
ISPR1#

Terakhir kita lakukan untuk setting routing antar router PE dengan routing protocol BGP

Code:
ISPR1
router bgp 1
neighbor 4.4.4.4 remote-as 1
neighbor 4.4.4.4 update-source Loopback0
no bgp default ipv4-unicast
address-family ipv4
neighbor 4.4.4.4 activate
address-family ipv4 vrf hacker_cisadane
redistribute rip

tambahkan redistribute bgp 1 metric 1 di router RIPnya

router rip
redistribute bgp 1 metric 1


ISPR4
router bgp 1
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback0
no bgp default ipv4-unicast
address-family ipv4
neighbor 1.1.1.1 activate
address-family ipv4 vrf hacker_cisadane
redistribute rip


tambahkan redistribute bgp 1 metric 1 di router RIPnya

router rip
redistribute bgp 1 metric 1

untuk cek routingnya udah kebaca atau blm dengan mengetikan perintah-perintah ini

cek bgp di internal ISP sudah UP

Code:
ISPR1#sh ip bgp sum

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxR
4.4.4.4         4     1      98      95        1    0    0 00:19:42        0

Routing untuk VRF hacker_cisadane jga udah kebaca

Code:
ISPR1#sh ip bgp vpnv4 v hacker_cisadane
BGP table version is 61, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1.1.1.1:1 (default for vrf hacker_cisadane)
*> 150.0.1.0/24     174.0.1.2                1         32768 ?
*>i150.0.2.0/24     4.4.4.4                  1    100      0 ?
*> 150.0.10.0/24    174.0.1.2                1         32768 ?
*>i150.0.20.0/24    4.4.4.4                  1    100      0 ?
*> 174.0.1.0/30     0.0.0.0                  0         32768 ?
*>i174.0.2.0/30     4.4.4.4                  0    100      0 ?
ISPR1#



Test ping dengan vrf jga udah replay sekarang jika mau ping harus pake vrfnya, coba klo ga pake vrf pasti RTO bisa di coba ya

ISPR1#ping vrf hacker_cisadane 150.0.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.0.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 136/181/252 ms
ISPR1#

Cek forwarding table di mpls

ISPR4# sh mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 16 192.168.12.0/24 0 Fa0/0 192.168.34.2
17 17 1.0.0.0/8 0 Fa0/0 192.168.34.2
18 Pop tag 192.168.23.0/24 0 Fa0/0 192.168.34.2
19 Pop tag 3.0.0.0/8 0 Fa0/0 192.168.34.2
20 19 2.0.0.0/8 0 Fa0/0 192.168.34.2
21 Aggregate 174.0.2.0/30[V] 0
22 Untagged 150.0.20.0/24[V] 0 Se1/0 point2point
23 Untagged 150.0.2.0/24[V] 2712 Se1/0 point2point

ISPR4#

Category: Cisco | Views: 1631 | Added by: Ardi | Rating: 0.0/0
Total comments: 2
2  
senang klo bisa membantu biggrin

1  
Terima kasih mas ilmunya..klo ada yang terbaru share y.. :)

Name *:
Email *:
Code *:
  SHAREIT   Main   Registration   Login  
search

Entries archive

MY Link
Paid2YouTube.com
Adsense Indonesia
Review shareit.ucoz.net on alexa.com

ilkan

WIDGET

Site friends
  • M. Danu Wiyoto
  • Hacker Cisadane


  • Copyright MyCorp © 2017 Free web hostinguCoz