Welcome Guest | RSS

My Menu

Calendar
«  Februari 2012  »
SuMoTuWeThFrSa
   1234
567891011
12131415161718
19202122232425
26272829

CATEGORY

Recent News

Iklan

Main » 2012 » Februari » 21 » BGP Multihoming ( mode Main and Backup Link with single ISP )
15.00
BGP Multihoming ( mode Main and Backup Link with single ISP )


sekarang saya ingin sharing kembali tentang networking yaitu BGP Multihoming. ada beberapa modem BGP Multihoming :

BGP Multihoming dengan 1 ISP

- mode Main dan Backup
- mode Load Sharing

BGP Multihoming dengan beda ISP

- mode Main dan Backup
- mode Load Sharing

yang sakarang mau saya bahas ada BGP Multihoming mode Main dan Backup link dengan 1 ISP yang sama.biasanya di pergunakan untuk sebuah customer yang ingin mempunyai backhaul dan ingin ada backup link yang stand by jikalau main link down.

ok gak perlu berlama-lama langsung aja saya mulai, pertama dengan topologi yang saya buat dan skenario apa saja yang di inginkan.

disini R1 di fungsikan sebagai Router Backhaul dengan single Router (main dan backhaul di dalam 1 router), R2 dan R3 di fungsikan sebagai Router ISP yang satu network, R4 di fungsikan sebagai branch customer.

Untuk detail topologi di bawah 

Topologi BGP Multihomming dengan single Router

Skenario

  1. baik Mainlink dan Backup di kesemua router BGP UP
  2. Traffic dari internal (outbound) router R1 ( Backhaul Router ) mengarah ke Main Link R2 ( 172.16.1.0/30)
  3. jika link dari R1 ke R2 down ( main Link Down ) link akan langsung mengarah ke Backup link R1 ke R3 ( 172.16.1.4/30)
  4. jika link dari R1 ke R2( Main Link ) sudah up , link akan otomatis akan kembali ke main link R1 ( 172.16.1.0/32)
  5. Jika link dari R2 ke arah branch R4 down link akan melalui R3 ke R4, begitu juga sebalinknya jika link dari R2 ke R3 Up.

berikut Konfigurasinya :

R1


hostname R1
!

interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface Loopback1
 ip address 11.11.11.11 255.255.255.255
!
interface Loopback2
 ip address 12.12.12.12 255.255.255.255
!
interface FastEthernet0/0
 description Main Link
 ip address 172.16.1.2 255.255.255.252
!
interface FastEthernet1/0
 description backup link
 ip address 172.16.1.6 255.255.255.252
!
router bgp 65000
network 10.10.10.10 mask 255.255.255.255
network 11.11.11.11 mask 255.255.255.255
network 12.12.12.12 mask 255.255.255.255
network 172.16.1.0 mask 255.255.255.252
network 172.16.1.4 mask 255.255.255.252
neighbor 172.16.1.1 remote-as 11111
neighbor 172.16.1.1 route-map OUTBOUND in // Berfungsi untuk mengarahkan traffic keluar mengarah dari R1 ke R2 ( Mainlink 172.16.1.1 ) dengan set weight 100 di route-map
neighbor 172.16.1.1 route-map MAIN-IN out // Berfungsi untuk mengarahkan traffic masuk mengarah ke R1 melalui R2 ( Main link) dengan set metric 100 di route-map lebih tinggi dari BACKUP-IN dengan metric 110
neighbor 172.16.1.5 remote-as 11111
neighbor 172.16.1.5 route-map BACKUP-IN out
!
ip access-list standard LAN
 permit 10.10.10.10
 permit 11.11.11.11
 permit 12.12.12.12
route-map OUTBOUND permit 10
 set weight 100
!
route-map MAIN-IN permit 10
 match ip address LAN
 set metric 100
!
route-map MAIN-IN permit 20
!
route-map BACKUP-IN permit 10
 match ip address LAN
 set metric 110
!
route-map BACKUP-IN permit 20


R2

hostname R2
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.252
!
interface FastEthernet0/1
 ip address 172.16.2.1 255.255.255.252
!
interface FastEthernet1/0
 ip address 23.23.23.1 255.255.255.252
!
router bgp 11111
network 2.2.2.2 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.252
network 172.16.1.0 mask 255.255.255.252
network 172.16.2.0 mask 255.255.255.252
neighbor 23.23.23.2 remote-as 11111
neighbor 172.16.1.2 remote-as 65000
neighbor 172.16.2.2 remote-as 65001

R3

hostname R3
!
interface FastEthernet0/1
 ip address 23.23.23.2 255.255.255.252
!
interface FastEthernet1/0
 ip address 172.16.1.5 255.255.255.252
!
interface FastEthernet1/1
 ip address 172.16.2.5 255.255.255.252
!
router bgp 11111
network 23.23.23.0 mask 255.255.255.252
network 172.16.1.4 mask 255.255.255.252
network 172.16.2.4 mask 255.255.255.252
neighbor 23.23.23.1 remote-as 11111
neighbor 172.16.1.6 remote-as 65000
neighbor 172.16.2.6 remote-as 65001


R4

hostname R4
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/1
 ip address 172.16.2.2 255.255.255.252
!
interface FastEthernet1/1
 ip address 172.16.2.6 255.255.255.252
!
router bgp 65001
network 4.4.4.4 mask 255.255.255.255
network 172.16.2.0 mask 255.255.255.252
network 172.16.2.4 mask 255.255.255.252
neighbor 172.16.2.1 remote-as 11111
neighbor 172.16.2.5 remote-as 11111

Konfigurasi sudah di lakukan sekarang cek BGP di Semua Router.

R1#sh ip bgp sum
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.1.1      4 11111      29      29       17    0    0 00:22:05        7
172.16.1.5      4 11111      28      29       17    0    0 00:21:59        7
R1#

R2#sh ip bgp sum
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
23.23.23.2      4 11111      27      28       17    0    0 00:22:50        4
172.16.1.2      4 65000      29      29       17    0    0 00:22:39        5
172.16.2.2      4 65001      19      29       17    0    0 00:22:34        3
R2#

R3#sh ip bgp sum
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
23.23.23.1      4 11111      29      28       21    0    0 00:23:24        8
172.16.1.6      4 65000      31      30       21    0    0 00:23:07        5
172.16.2.6      4 65001      20      30       21    0    0 00:23:09        3
R3#

R4#sh ip bgp sum
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.2.1      4 11111      30      20       22    0    0 00:12:21        9
172.16.2.5      4 11111      30      20       22    0    0 00:12:22        9
R4#

BGP sudah UP di semua router sekarang pastikan outbound dari router R1 mengarah ke R2 ( Main Link )
skenario 1 ok

Cek Routing dan traceroute dari R1 ke R4

R1#sh ip bgp 4.4.4.4 
BGP routing table entry for 4.4.4.4/32, version 17
Paths: (2 available, best #2)
  Advertised to update-groups:
     1
  11111 65001
    172.16.1.5 from 172.16.1.5 (172.16.2.5)
      Origin IGP, localpref 100, valid, external
  11111 65001
    172.16.1.1 from 172.16.1.1 (2.2.2.2)
      Origin IGP, localpref 100, weight 100, valid, external, best

R1#traceroute 4.4.4.4

Type escape sequence to abort.
Tracing the route to 4.4.4.4

  1 172.16.1.1 16 msec 52 msec 60 msec ( Router R2)
  2 172.16.2.2 [AS 11111] 124 msec 52 msec * (Router R4)
R1#

Cek BGP Routing dari Outbond R1 ke Lo0 R4 sudah mengarah ke R2 ( Main Link ) skenario 2 OK, di skenario 3 apabila main link down(R1 - R2 down) traffic harus berpindah ke R3

link dari R1 - R2 Down

R1#sh ip bgp sum
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.1.1      4 11111      43      43        0    0    0 00:00:16 Idle ( main link sudah down)
172.16.1.5      4 11111      43      46       24    0    0 00:36:24        7
R1#
R4#traceroute 10.10.10.10 ( trace dari R4 ke arah Lo0 R1 backhaul)

Type escape sequence to abort.
Tracing the route to 10.10.10.10

  1 172.16.2.5 4 msec 12 msec 48 msec (Router R3)
  2 172.16.1.6 [AS 11111] 48 msec 8 msec *(Router R1)
R4#

Traffic yang mengarah ke R1 sudah mengarah ke Backup Link melalui R3 dan skenario 3 Berhasil, untuk skenario 4 apabila R1 ke R2 kembali up traffic harus kembali lagi ke main link ( R1-R2)

BGP Main link dari R1 ke R2 sudah up

R1#sh ip bgp sum
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.1.1      4 11111      61      58       35    0    0 00:07:42        7
172.16.1.5      4 11111      62      66       35    0    0 00:50:35        7
R1#
R4#traceroute 10.10.10.10

Type escape sequence to abort.
Tracing the route to 10.10.10.10

  1 172.16.2.1 40 msec 36 msec 24 msec (Router R2)
  2 172.16.1.2 [AS 11111] 24 msec 8 msec * (Router R1)
R4#

skenario 4 berhasil link dari R1 ke R2 Up traffic mengarah kembali ke R2 ( Main Link), untuk skenario terakhir jika interface R2 yang mengarah ke R4 down, traffic harus melalui R3 dahulu baru ke R2 kemudian ke R1

R2#sh ip bgp sum
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
23.23.23.2      4 11111      65      66       37    0    0 00:55:27        5
172.16.1.2      4 65000      64      71       35    0    0 00:12:17        5
172.16.2.2      4 65001      49      75        0    0    0 00:00:07 Idle
R2#
R4#traceroute 10.10.10.10 ( trace dari R4 ke Arah Lo0 R1 )

Type escape sequence to abort.
Tracing the route to 10.10.10.10

  1 172.16.2.5 8 msec 60 msec 120 msec (Router R3)
  2 23.23.23.1 [AS 11111] 24 msec 12 msec 48 msec (Router R2)
  3 172.16.1.2 [AS 11111] 96 msec 36 msec * (Router R1)
R4#

traceroute sudah berhasil dari R4 - R3 - R2 - R1 skenario 5 berhasil done



itu dulu untuk BGP Multihoming





sebagai pembaca yang baik jangan lupa tinggalkan jejak dan klik iklannya ya 


Category: Cisco | Views: 564 | Added by: Ardi | Rating: 0.0/0
Total comments: 0
Name *:
Email *:
Code *:
  SHAREIT   Main   Registration   Login  
search

Entries archive

MY Link
Paid2YouTube.com
Adsense Indonesia
Review shareit.ucoz.net on alexa.com

ilkan

WIDGET

Site friends
  • M. Danu Wiyoto
  • Hacker Cisadane


  • Copyright MyCorp © 2017 Free web hostinguCoz