Welcome Guest | RSS

My Menu

Calendar
«  Februari 2012  »
SuMoTuWeThFrSa
   1234
567891011
12131415161718
19202122232425
26272829

CATEGORY

Recent News

Iklan

Main » 2012 » Februari » 22 » BGP Multihoming Loadsharing dengan single ISP
12.30
BGP Multihoming Loadsharing dengan single ISP


dengan melanjutkan tutorial ini tentang BGP Multihoming, sekarang saya akan memaksimalkan R4 sebagai Branch Customer yang mempunyai 2 link, yang notabene BGP secara default hanya mengunakan 1 jalur saja. kita akan menggunakan topologi yang sama.





Konfigurasi Sebelumnya untuk R4 sebagai berikut

R4

hostname R4
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/1
 ip address 172.16.2.2 255.255.255.252
!
interface FastEthernet1/1
 ip address 172.16.2.6 255.255.255.252
!
router bgp 65001
network 4.4.4.4 mask 255.255.255.255
network 172.16.2.0 mask 255.255.255.252
network 172.16.2.4 mask 255.255.255.252
neighbor 172.16.2.1 remote-as 11111
neighbor 172.16.2.5 remote-as 11111

Dengan konfigurasi seperti ini R4 mempunya 2 jalur BGP tetapi hanya 1 jalur yang di pergunakan, untuk mengaktifkan loadsharing dengan perintah

R4

Router bgp 65001
maximum-paths 2 ( mengaktifkan multipath max 2 jalur)
do cle ip bgp * ( clear bgp setiap ada perubahan di konfigurasi bgp )


pengecekan routing sebelum di pasang maximum-paths sbb :

R4#sh ip rou bgp
     2.0.0.0/32 is subnetted, 1 subnets
B       2.2.2.2 [20/0] via 172.16.2.5, 00:04:33
     23.0.0.0/30 is subnetted, 1 subnets
B       23.23.23.0 [20/0] via 172.16.2.5, 00:04:33
     172.16.0.0/30 is subnetted, 4 subnets
B       172.16.1.4 [20/0] via 172.16.2.5, 00:04:33
B       172.16.1.0 [20/0] via 172.16.2.5, 00:04:33
     10.0.0.0/32 is subnetted, 1 subnets
B       10.10.10.10 [20/0] via 172.16.2.5, 00:04:33
     11.0.0.0/32 is subnetted, 1 subnets
B       11.11.11.11 [20/0] via 172.16.2.5, 00:04:33
     12.0.0.0/32 is subnetted, 1 subnets
B       12.12.12.12 [20/0] via 172.16.2.5, 00:04:33
R4#
R4#sh ip rou 10.10.10.10
Routing entry for 10.10.10.10/32
  Known via "bgp 65001", distance 20, metric 0
  Tag 11111, type external
  Last update from 172.16.2.5 00:04:24 ago
  Routing Descriptor Blocks:
  * 172.16.2.5, from 172.16.2.5, 00:04:24 ago
      Route metric is 0, traffic share count is 1
      AS Hops 2, BGP network version 0
      Route tag 11111

setelah memasang maximum-paths 2 sbb :

R4#sh ip rou bgp
     2.0.0.0/32 is subnetted, 1 subnets
B       2.2.2.2 [20/0] via 172.16.2.1, 00:00:46
                [20/0] via 172.16.2.5, 00:00:40
     23.0.0.0/30 is subnetted, 1 subnets
B       23.23.23.0 [20/0] via 172.16.2.1, 00:00:46
                   [20/0] via 172.16.2.5, 00:00:40
     172.16.0.0/30 is subnetted, 4 subnets
B       172.16.1.4 [20/0] via 172.16.2.1, 00:00:46
                   [20/0] via 172.16.2.5, 00:00:40
B       172.16.1.0 [20/0] via 172.16.2.1, 00:00:46
                   [20/0] via 172.16.2.5, 00:00:40
     10.0.0.0/32 is subnetted, 1 subnets
B       10.10.10.10 [20/0] via 172.16.2.1, 00:00:46
                    [20/0] via 172.16.2.5, 00:00:40
     11.0.0.0/32 is subnetted, 1 subnets
B       11.11.11.11 [20/0] via 172.16.2.1, 00:00:46
                    [20/0] via 172.16.2.5, 00:00:40
     12.0.0.0/32 is subnetted, 1 subnets
B       12.12.12.12 [20/0] via 172.16.2.1, 00:00:46
                    [20/0] via 172.16.2.5, 00:00:40
R4# 
R4#sh ip rou 10.10.10.10
Routing entry for 10.10.10.10/32
  Known via "bgp 65001", distance 20, metric 0
  Tag 11111, type external
  Last update from 172.16.2.5 00:02:45 ago
  Routing Descriptor Blocks:
  * 172.16.2.1, from 172.16.2.1, 00:02:51 ago
      Route metric is 0, traffic share count is 1
      AS Hops 2, BGP network version 0
      Route tag 11111
    172.16.2.5, from 172.16.2.5, 00:02:45 ago
      Route metric is 0, traffic share count is 1
      AS Hops 2, BGP network version 0
      Route tag 11111

R4#

sekarang dengan cek sh ip route bgp sudah melewati 2 jalur, coba show routing ke Lo0 R1 sudah melewati 2 jalur yang sebelumnya hanya menggunakan 1 jalur bgp walaupun mempunyai 2 jalur.

Load Sharing sudah berhasil di aplikasikan di R4( Branch Customer) untuk selanjutnya saya akan membagi access ke Backhaul customer (Router R1) per IP address. di belakang network R1 mempunya 3 IP dan pembagian akan di skenariokan sbb :

  1. Router R4 yang akan mengakses IP 10.10.10.10 dan 11.11.11.11 akan melalui R2 kemudian ke R1
  2. Rotuer R4 yang akan mengakses IP 12.12.12.12 akan melalui R3,R2, baru kemudian ke R1
  3. jika salah satu jalur baik dari R2 ke R4 atau dari R3 ke R4 down, traffic akan di alihkan ke jalur yang masih UP.

tambahkan konfigurasi sebagai berikut di router R4


ip prefix-list FULL seq 5 permit 10.10.10.10/32
ip prefix-list FULL seq 10 permit 11.11.11.11/32
ip prefix-list FULL seq 15 permit 12.12.12.12/32
ip prefix-list CORE seq 5 permit 10.10.10.10/32
ip prefix-list CORE seq 10 permit 11.11.11.11/32
ip prefix-list LAN seq 5 permit 4.4.4.4/32
ip prefix-list SEC-APP seq 5 permit 12.12.12.12/32

route-map CORE permit 10
 match ip address prefix-list CORE
 set weight 200
route-map CORE permit 20

route-map SEC-APP permit 10
 match ip address prefix-list SEC-APP
 set weight 200
route-map SEC-APP permit 20

router bgp 65001
neighbor LOAD peer-group
neighbor LOAD timers 10 30
neighbor LOAD prefix-list FULL in
neighbor LOAD prefix-list LAN out
neighbor 172.16.2.1 remote-as 11111
neighbor 172.16.2.1 peer-group LOAD
neighbor 172.16.2.1 route-map CORE in
neighbor 172.16.2.5 remote-as 11111
neighbor 172.16.2.5 peer-group LOAD
neighbor 172.16.2.5 route-map SEC-APP in


setelah konfigurasi di pasang lakukan clear BGP, untuk skenario 1 dan 2 pastikan R4 sudah membagi traffic ke R1 sesuai prefix-list yang di pasang di BGP

R4#sh ip rou bgp
     10.0.0.0/32 is subnetted, 1 subnets
B       10.10.10.10 [20/0] via 172.16.2.1, 00:06:26 ( melewati R2 )
     11.0.0.0/32 is subnetted, 1 subnets
B       11.11.11.11 [20/0] via 172.16.2.1, 00:06:26 ( melewati R2 )
     12.0.0.0/32 is subnetted, 1 subnets
B       12.12.12.12 [20/0] via 172.16.2.5, 00:06:31 ( melewati R3 )
R4#
R4#traceroute 10.10.10.10

Type escape sequence to abort.
Tracing the route to 10.10.10.10

  1 172.16.2.1 44 msec 12 msec 60 msec
  2 172.16.1.2 128 msec 72 msec *
R4#traceroute 12.12.12.12

Type escape sequence to abort.
Tracing the route to 12.12.12.12

  1 172.16.2.5 12 msec 36 msec 12 msec
  2 23.23.23.1 100 msec 108 msec 68 msec
  3 172.16.1.2 140 msec 120 msec *
R4#

untuk Skenario 1 dan 2 sudah berhasil, untuk skenario 3 downkan salah satu jalur untuk memastikan prefix-list FULL yang di pasang BGP berjalan saling backup, pertama saya akan mensimulasi jalur dari R2- R4 down.

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.2.1      4 11111     107     102        0    0    0 00:00:09 Idle ( R2-R4 sudah down)
172.16.2.5      4 11111     107     106       83    0    0 00:11:29        3

R4#sh ip rou bgp
     10.0.0.0/32 is subnetted, 1 subnets
B       10.10.10.10 [20/0] via 172.16.2.5, 00:00:23
     11.0.0.0/32 is subnetted, 1 subnets
B       11.11.11.11 [20/0] via 172.16.2.5, 00:00:23
     12.0.0.0/32 is subnetted, 1 subnets
B       12.12.12.12 [20/0] via 172.16.2.5, 00:11:43
R4#
R4#traceroute 10.10.10.10

Type escape sequence to abort.
Tracing the route to 10.10.10.10

  1 172.16.2.5 48 msec 36 msec 20 msec
  2 23.23.23.1 64 msec 60 msec 64 msec
  3 172.16.1.2 124 msec 92 msec *
R4#

Traffic yang mengarah ke IP 10.10.10.10 di R1 dari R4 yang harusnya melalui R2 sudah di alihkan secara otomatis ke ke R3 dahulu sebelum ke R2 lalu ke R1 di karenakan jalur dari R2-R4 down. sekarang saya akan melakukan down interface yang mengarah ke R3

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.2.1      4 11111     131     121       94    0    0 00:01:30        3
172.16.2.5      4 11111     144     143        0    0    0 00:02:42 Idle ( jalur ke R3 down )
R4#
R4#sh ip rou bgp
     10.0.0.0/32 is subnetted, 1 subnets
B       10.10.10.10 [20/0] via 172.16.2.1, 00:00:28
     11.0.0.0/32 is subnetted, 1 subnets
B       11.11.11.11 [20/0] via 172.16.2.1, 00:00:28
     12.0.0.0/32 is subnetted, 1 subnets
B       12.12.12.12 [20/0] via 172.16.2.1, 00:00:28
R4#
R4#traceroute 12.12.12.12

Type escape sequence to abort.
Tracing the route to 12.12.12.12

  1 172.16.2.1 4 msec 36 msec 60 msec
  2 172.16.1.2 64 msec 44 msec *
R4#

dari hasil test di atas sudah berjalan loadsharing BGP sesuai skenario yang di inginkan






Category: Cisco | Views: 632 | Added by: Ardi | Rating: 0.0/0
Total comments: 0
Name *:
Email *:
Code *:
  SHAREIT   Main   Registration   Login  
search

Entries archive

MY Link
Paid2YouTube.com
Adsense Indonesia
Review shareit.ucoz.net on alexa.com

ilkan

WIDGET

Site friends
  • M. Danu Wiyoto
  • Hacker Cisadane


  • Copyright MyCorp © 2017 Free web hostinguCoz